summaryrefslogtreecommitdiff
path: root/src/arch/sharing/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-11-27 23:35:47 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-11-27 23:35:47 (GMT)
commit7d6d3acb65586ad9512a38b58c16b9a21cdf98e0 (patch)
tree9ae21078e24c997b80a24d8d71ed5ad1be74c850 /src/arch/sharing/Makefile.am
parent3eacf14cc395e7fd0ab5dd5e9d22bb93a6a02979 (diff)
Saved memory space by sharing arch GObjects.
Diffstat (limited to 'src/arch/sharing/Makefile.am')
-rw-r--r--src/arch/sharing/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/arch/sharing/Makefile.am b/src/arch/sharing/Makefile.am
new file mode 100644
index 0000000..46496c2
--- /dev/null
+++ b/src/arch/sharing/Makefile.am
@@ -0,0 +1,14 @@
+
+noinst_LTLIBRARIES = libarchsharing.la
+
+libarchsharing_la_SOURCES = \
+ instance-int.h \
+ instance.h instance.c \
+ manager.h manager.c
+
+libarchdalvik_la_CFLAGS = $(AM_CFLAGS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)