summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2023-01-29 17:37:16 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2023-01-29 17:37:16 (GMT)
commit0507bdb3b56083c8e8b011fc3d4c16fed2700340 (patch)
treeb9ea8102d32e8ee68794678bd95dce911e8ef467 /src/common/Makefile.am
parent1d07407c3e97611bbf7c15ed6c1d6b8a37b0e228 (diff)
Retrieve CPU capabilities.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 638eee0..2f6fd6d 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -9,6 +9,7 @@ libcommon_la_SOURCES = \
bits.h bits.c \
compression.h compression.c \
cpp.h \
+ cpu.h cpu.c \
dllist.h dllist.c \
endianness.h endianness.c \
environment.h environment.c \
@@ -37,6 +38,8 @@ libcommon_la_SOURCES += \
endif
+cpu.lo: CFLAGS += -mavx512f
+
libcommon_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
if BUILD_CURL_SUPPORT