summaryrefslogtreecommitdiff
path: root/src/format/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2008-08-08 09:28:16 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2008-08-08 09:28:16 (GMT)
commit904476ddf621d9513bf90a3fa396d2e6c1ea2952 (patch)
treef8966baa2ea80d2c2068a85b24ead1e651d17dc9 /src/format/Makefile.am
parent0153acaaf41e97477f6c484a92c2dd46f5122300 (diff)
Prepared to handle the DWARF debug format.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@15 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/format/Makefile.am')
-rw-r--r--src/format/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/src/format/Makefile.am b/src/format/Makefile.am
index 99afa2e..acc849b 100644
--- a/src/format/Makefile.am
+++ b/src/format/Makefile.am
@@ -1,2 +1,19 @@
-SUBDIRS = elf
+lib_LIBRARIES = libformat.a
+
+libformat_a_SOURCES = \
+ exe_format.h exe_format.c \
+ exe_format-int.h \
+ dbg_format.h dbg_format.c \
+ dbg_format-int.h
+
+libformat_a_CFLAGS = $(AM_CFLAGS)
+
+
+INCLUDES =
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
+
+SUBDIRS = dwarf elf