summaryrefslogtreecommitdiff
path: root/src/format/mangling/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-03-08 22:05:09 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-03-08 22:05:09 (GMT)
commit29a22c425f492427f45b71de937f2d99587c8d34 (patch)
tree36e8bb3ef73bc91e812ed63205d10bfced578660 /src/format/mangling/Makefile.am
parent674739bedc853681be5a2657a7a4f497d6e82c9b (diff)
Added a partial support of the Itanium C++ ABI mangling.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@52 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/format/mangling/Makefile.am')
-rw-r--r--src/format/mangling/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/format/mangling/Makefile.am b/src/format/mangling/Makefile.am
new file mode 100644
index 0000000..71a0923
--- /dev/null
+++ b/src/format/mangling/Makefile.am
@@ -0,0 +1,25 @@
+
+BUILT_SOURCES = itanium_gram.h
+
+AM_YFLAGS = -d
+
+lib_LIBRARIES = libformatmangling.a
+
+libformatmangling_a_SOURCES = \
+ demangler.h demangler.c \
+ itanium.h \
+ itanium_gram.y \
+ itanium_tok.l
+
+libformatmangling_a_CFLAGS = $(AM_CFLAGS)
+
+
+INCLUDES = $(LIBGTK_CFLAGS)
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
+
+
+# Automake fait les choses à moitié
+CLEANFILES = itanium_gram.h itanium_gram.c itanium_tok.c