summaryrefslogtreecommitdiff
path: root/src/glibext/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-12-16 21:26:35 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-12-16 21:26:35 (GMT)
commit2581d80875304c466e8930dbe67986ceb95752b2 (patch)
treed505d7642eae78e90d401bdebb2849b3ff970223 /src/glibext/Makefile.am
parentf89f72f53b42c704dcb5767e508747795f7115c6 (diff)
Fixed the compilation by processing the GLib marshals sooner.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@303 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/glibext/Makefile.am')
-rw-r--r--src/glibext/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/glibext/Makefile.am b/src/glibext/Makefile.am
index d5235c8..b6f100b 100644
--- a/src/glibext/Makefile.am
+++ b/src/glibext/Makefile.am
@@ -1,7 +1,10 @@
+BUILT_SOURCES = chrysamarshal.h chrysamarshal.c
+
noinst_LTLIBRARIES = libglibext.la
libglibext_la_SOURCES = \
+ chrysamarshal.h chrysamarshal.c \
delayed-int.h \
delayed.h delayed.c \
gbufferline.h gbufferline.c \
@@ -21,3 +24,11 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
SUBDIRS =
+
+
+chrysamarshal.h: chrysamarshal.list
+ glib-genmarshal --header $< > $@
+
+chrysamarshal.c: chrysamarshal.list
+ echo "#include <$(subst .c,.h,$@)>" > $@
+ glib-genmarshal --body $< >> $@