summaryrefslogtreecommitdiff
path: root/src/glibext/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-12-30 10:38:52 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-12-30 10:38:52 (GMT)
commit932ea7c83c07d3982fee605c6dd9895fd2753874 (patch)
tree766ad53bab9e3e3005334c30e823493de8e84168 /src/glibext/Makefile.am
parent1b5d39bfbc48c33a0ea0924b60e48448c8b45dd4 (diff)
Rewritten the line buffers using generators and on-demand building to save memory.
Diffstat (limited to 'src/glibext/Makefile.am')
-rw-r--r--src/glibext/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/glibext/Makefile.am b/src/glibext/Makefile.am
index aa7a9a3..fe7565a 100644
--- a/src/glibext/Makefile.am
+++ b/src/glibext/Makefile.am
@@ -9,16 +9,21 @@ libglibext_la_SOURCES = \
delayed-int.h \
delayed.h delayed.c \
gbinportion.h gbinportion.c \
+ gbuffercache.h gbuffercache.c \
gbufferline.h gbufferline.c \
gbufferview.h gbufferview.c \
- gcodebuffer.h gcodebuffer.c \
gnhash.h gnhash.c \
gwidthtracker.h gwidthtracker.c \
linecolumn.h linecolumn.c \
+ linegen-int.h \
+ linegen.h linegen.c \
linesegment.h linesegment.c \
proto.h \
signal.h signal.c
+libglibext_la_LIBADD = \
+ generators/libglibextgenerators.la
+
libglibext_la_LDFLAGS =
@@ -26,7 +31,7 @@ AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS =
+SUBDIRS = generators
chrysamarshal.h: chrysamarshal.list