summaryrefslogtreecommitdiff
path: root/src/gtkext/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-10-17 22:38:38 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-10-17 22:38:38 (GMT)
commitaf29afcc9a37113e4187b1c0a20e3bf5e2dcd4d9 (patch)
tree46da4b3886b43d4bb549aa01012bda13ce36c375 /src/gtkext/Makefile.am
parented846003946a44588c7c131b9c9001f97bf10711 (diff)
Removed a lot of gcc warnings.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@272 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/gtkext/Makefile.am')
-rw-r--r--src/gtkext/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/src/gtkext/Makefile.am b/src/gtkext/Makefile.am
index 67d1a49..f590693 100644
--- a/src/gtkext/Makefile.am
+++ b/src/gtkext/Makefile.am
@@ -6,13 +6,9 @@ noinst_LTLIBRARIES = libgtkext.la
libgtkext_la_SOURCES = \
easygtk.h easygtk.c \
gtkextstatusbar.h gtkextstatusbar.c \
- gtkbinview-int.h \
- gtkbinview.h gtkbinview.c \
gtkblockview.h gtkblockview.c \
gtkbufferview-int.h \
gtkbufferview.h gtkbufferview.c \
- gtkdockitem.h gtkdockitem.c \
- gtkdockpanel.h gtkdockpanel.c \
gtkdockstation.h gtkdockstation.c \
gtkgraphview.h gtkgraphview.c \
gtklinkrenderer.h gtklinkrenderer.c \
@@ -36,4 +32,5 @@ iodamarshal.h: iodamarshal.list
glib-genmarshal --header $< > $@
iodamarshal.c: iodamarshal.list
- glib-genmarshal --body $< > $@
+ echo "#include <$(subst .c,.h,$@)>" > $@
+ glib-genmarshal --body $< >> $@