summaryrefslogtreecommitdiff
path: root/src/gtkext/graph/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2013-03-19 21:13:51 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2013-03-19 21:13:51 (GMT)
commitcf97db0ea4d1ea983db38df85984034b49fa4f77 (patch)
treeb6d69945b24ec8da93f0bef7ccf4dfdbe1d920a2 /src/gtkext/graph/Makefile.am
parente7a85861ba8bcd00ceb7bf9e47f4eadccd48ce3f (diff)
Defined the first steps towards new graph renderings.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@345 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/gtkext/graph/Makefile.am')
-rwxr-xr-xsrc/gtkext/graph/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/gtkext/graph/Makefile.am b/src/gtkext/graph/Makefile.am
index a631a90..ead315a 100755
--- a/src/gtkext/graph/Makefile.am
+++ b/src/gtkext/graph/Makefile.am
@@ -3,10 +3,16 @@ noinst_LTLIBRARIES = libgtkextgraph.la
libgtkextgraph_la_SOURCES = \
dot.h dot.c \
+ edge.h edge.c \
layout.h layout.c \
- node.h node.c
+ node.h node.c \
+ params.h \
+ ranks.h ranks.c
-libgtkextgraph_la_LDFLAGS =
+libgtkextgraph_la_LIBADD = \
+ nodes/libgtkextgraphnodes.la
+
+libgtkextgraph_la_LDFLAGS =
INCLUDES = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBGRAPH_CFLAGS)
@@ -15,4 +21,4 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS =
+SUBDIRS = nodes