summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2014-10-07 22:07:27 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2014-10-07 22:07:27 (GMT)
commita5e162d47a574f334b172dfee3128a40e8d52fb3 (patch)
tree5816a46365d196f40ac39fed884a9ee20fb44194 /tools/Makefile.am
parent1d5f7f28f92251dc4d3bff8d87b3e3052ab9cab2 (diff)
Created a compiler for architecture instruction definitions.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@410 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..9a91f9d
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,25 @@
+
+BUILT_SOURCES = d2c-d2c_gram.h
+
+AM_YFLAGS = -d
+
+bin_PROGRAMS = d2c
+
+
+d2c_SOURCES = \
+ coder.h coder.c \
+ d2c_gram.y \
+ d2c_tok.l
+
+d2c_YFLAGS = -d -p d2c_ -o y.tab.c
+
+d2c_LFLAGS = -P d2c_ -o lex.yy.c
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
+
+
+# Automake fait les choses à moitié
+CLEANFILES = d2c_gram.h d2c_gram.c d2c-d2c_tok.c