summaryrefslogtreecommitdiff
path: root/tools/d2c/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-01-28 23:32:25 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-01-28 23:32:25 (GMT)
commit16e0fd9d89ef433848678dfc8dd20426844a2868 (patch)
tree79075ae02c133cea21ffb555b1086aae833b3aac /tools/d2c/Makefile.am
parent66c99d59d6a6d533de0bb65488de8243213bcdea (diff)
Cleaned, rewritten and improved the whole code of the compiler.
Diffstat (limited to 'tools/d2c/Makefile.am')
-rw-r--r--tools/d2c/Makefile.am49
1 files changed, 30 insertions, 19 deletions
diff --git a/tools/d2c/Makefile.am b/tools/d2c/Makefile.am
index 63ca5fe..e89384f 100644
--- a/tools/d2c/Makefile.am
+++ b/tools/d2c/Makefile.am
@@ -1,35 +1,46 @@
-BUILT_SOURCES = d2c-d2c_gram.h
+BUILT_SOURCES = grammar.h
+
+
+# On évite d'utiliser les variables personnalisées de type *_la_[YL]FLAGS
+# afin de conserver des noms de fichiers simples, ie sans le nom de la
+# bibliothèque de sortie en préfixe.
+
+AM_YFLAGS = -v -d -p d2c_
+
+AM_LFLAGS = -P d2c_ -o lex.yy.c --header-file=tokens.h \
+ -Dyylval=d2c_lval -Dyyget_lineno=d2c_get_lineno \
+ -Dyy_scan_bytes=d2c__scan_bytes \
+ -Dyy_delete_buffer=d2c__delete_buffer
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
-AM_YFLAGS = -d
bin_PROGRAMS = d2c
+.NOTPARALLEL: $(bin_PROGRAMS)
d2c_SOURCES = \
- args.h args.c \
- bits.h bits.c \
coder.h coder.c \
- conv.h conv.c \
- d2c_tok.l \
- d2c_gram.y \
+ tokens.l \
+ grammar.y \
helpers.h helpers.c \
- hooks.h hooks.c \
+ manual.h \
pproc.h pproc.c \
qckcall.h qckcall.c \
- rules.h rules.c \
- spec.h spec.c \
- syntax.h syntax.c
+ spec.h spec.c
-d2c_YFLAGS = -v -d -p d2c_ -o y.tab.c
+d2c_LDADD = \
+ bits/libd2cbits.la \
+ conv/libd2cconv.la \
+ hooks/libd2chooks.la \
+ rules/libd2crules.la \
+ syntax/libd2csyntax.la \
+ args/libd2cargs.la
-d2c_LFLAGS = -P d2c_ --header-file=d2c_tok.h -o lex.yy.c
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
+# Automake fait les choses à moitié
+CLEANFILES = grammar.h grammar.c grammar.output tokens.c tokens.h
-# Automake fait les choses à moitié
-CLEANFILES = d2c_gram.h d2c_gram.c d2c-d2c_tok.c
+SUBDIRS = args bits conv hooks rules syntax