summaryrefslogtreecommitdiff
path: root/tools/fuzzing/rost/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2023-11-13 01:20:17 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2023-11-13 01:20:17 (GMT)
commit6f1f98b46c4753bbbb5b763c64ada556170185b4 (patch)
treea50f2925dd5c1368dbf7f57c0c1a4033ae419b91 /tools/fuzzing/rost/Makefile.am
parente279139b7dcae080723412ea475787123c2389d4 (diff)
Provide some helpers to run ROST with AFL++.
Diffstat (limited to 'tools/fuzzing/rost/Makefile.am')
-rw-r--r--tools/fuzzing/rost/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/fuzzing/rost/Makefile.am b/tools/fuzzing/rost/Makefile.am
new file mode 100644
index 0000000..81e126f
--- /dev/null
+++ b/tools/fuzzing/rost/Makefile.am
@@ -0,0 +1,14 @@
+
+bin_PROGRAMS = fast-rost
+
+
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/src
+
+# EXTRA_rost_DEPENDENCIES = libchrysacore.la
+
+fast_rost_SOURCES = \
+ fast-rost.c
+
+fast_rost_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
+
+fast_rost_LDFLAGS = $(LIBGOBJ_LIBS) -L$(top_srcdir)/src/.libs -lchrysacore