summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7357b00..34a6b88 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@ BUILT_SOURCES = revision.h
@[ -d $@ ] || touch $@
revision.h: .svn
- @nb=`svn log ChangeLog -l 1 -q | grep r | cut -d ' ' -f 1 | tr -d 'r'` ; \
+ @nb=`LANG=C svn info | grep 'Revision:' | cut -d ' ' -f 2 | tr -d 'r'` ; \
cat $@.in | sed "s/#define REVISION .*$$/#define REVISION $$nb/" > $@ ; \
[ -f $< ] && rm $< || true