summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 13a6314..0bee3b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,9 +5,9 @@ BUILT_SOURCES = revision.h
@[ -d $@ ] || touch $@
revision.h: .svn
- @nb=`svn log . -l 1 -q | grep r | cut -d ' ' -f 1 | tr -d 'r'` ; \
+ @nb=`svn log ChangeLog -l 1 -q | grep r | cut -d ' ' -f 1 | tr -d 'r'` ; \
sed -i "s/#define REVISION .*$$/#define REVISION $$nb/" $@ ; \
- [ -f $< ] && rm $<
+ [ -f $< ] && rm $< || true
EXTRA_DIST = config.rpath config.rpath config.rpath config.rpath ChangeLog