summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 22 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index aadb326..98923d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,8 +95,9 @@ AC_CHECK_FUNCS([strrchr])
#--- Autoheader Macros
AH_TEMPLATE([REVISION], [Define the version number of the program for the about box.])
-AH_TEMPLATE([PACKAGE_DATA_DIR], [Define the directory where the associated data will be installed.])
AH_TEMPLATE([PACKAGE_SOURCE_DIR], [Define the directory where the code source is waiting for being compiled.])
+AH_TEMPLATE([PIXMAPS_DIR], [Define the directory where the pictures will be installed.])
+AH_TEMPLATE([THEMES_DIR], [Define the main directory where all themes will be installed.])
AH_TEMPLATE([PLUGINS_DIR], [Define the directory where the plugins are installed.])
AH_TEMPLATE([LOCALE_DIR], [Define the directory where the message catalogs are installed.])
@@ -105,28 +106,41 @@ AC_DEFINE_UNQUOTED(REVISION, AC_PACKAGE_VERSION)
if test "x${datadir}" = 'x${prefix}/share'; then
if test "x${prefix}" = "xNONE"; then
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${ac_default_prefix}/share/${PACKAGE}")
+ pkgdatadir="${ac_default_prefix}/share/${PACKAGE}"
else
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${prefix}/share/${PACKAGE}")
+ pkgdatadir="${prefix}/share/${PACKAGE}"
fi
elif test "x${datadir}" = 'x${datarootdir}'; then
if test "x${datarootdir}" = 'x${prefix}/share'; then
if test "x${prefix}" = "xNONE"; then
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${ac_default_prefix}/share/${PACKAGE}")
+ pkgdatadir="${ac_default_prefix}/share/${PACKAGE}"
else
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${prefix}/share/${PACKAGE}")
+ pkgdatadir="${prefix}/share/${PACKAGE}"
fi
else
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${datarootdir}/${PACKAGE}")
+ pkgdatadir="${datarootdir}/${PACKAGE}"
fi
else
- AC_DEFINE_UNQUOTED(PACKAGE_DATA_DIR, "${datadir}/${PACKAGE}")
+ pkgdatadir="${datadir}/${PACKAGE}"
fi
packagesrcdir=`cd $srcdir && pwd`
AC_DEFINE_UNQUOTED(PACKAGE_SOURCE_DIR, "${packagesrcdir}")
-AC_DEFINE_UNQUOTED(PLUGINS_DIR, PACKAGE_DATA_DIR "/plugins")
+pixmapsdir="${pkgdatadir}/pixmaps"
+AC_SUBST(pixmapsdir)
+
+AC_DEFINE_UNQUOTED(PIXMAPS_DIR, "${pixmapsdir}")
+
+themesdir="${pkgdatadir}/themes"
+AC_SUBST(themesdir)
+
+AC_DEFINE_UNQUOTED(THEMES_DIR, "${themesdir}")
+
+pluginsdir="${pkgdatadir}/plugins"
+AC_SUBST(pluginsdir)
+
+AC_DEFINE_UNQUOTED(PLUGINS_DIR, "${pluginsdir}")
if test "x${prefix}" = "xNONE"; then
AC_DEFINE_UNQUOTED(LOCALE_DIR, "${ac_default_prefix}/share/locale")