summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3759c75..a78cf1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,6 +100,7 @@ AH_TEMPLATE([PIXMAPS_DIR], [Define the directory where the pictures will be inst
AH_TEMPLATE([THEMES_DIR], [Define the main directory where all themes will be installed.])
AH_TEMPLATE([PLUGINS_LIB_DIR], [Define the directory where the plugin librairies are installed.])
AH_TEMPLATE([PLUGINS_DATA_DIR], [Define the directory where the plugin data is installed.])
+AH_TEMPLATE([BUILD_PREFIX_DIR], [Define the prefix for all installation directories.])
AH_TEMPLATE([LOCALE_DIR], [Define the directory where the message catalogs are installed.])
@@ -172,6 +173,8 @@ if echo ${basedir} | grep -q '^NONE'; then
AC_MSG_FAILURE([NONE found in \$prefix])
fi
+AC_DEFINE_UNQUOTED(BUILD_PREFIX_DIR, "${basedir}")
+
AC_DEFINE_UNQUOTED(LOCALE_DIR, "${basedir}/share/locale")