summaryrefslogtreecommitdiff
path: root/plugins/apihashing/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/apihashing/Makefile.am')
-rw-r--r--plugins/apihashing/Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/plugins/apihashing/Makefile.am b/plugins/apihashing/Makefile.am
new file mode 100644
index 0000000..d73f8b0
--- /dev/null
+++ b/plugins/apihashing/Makefile.am
@@ -0,0 +1,65 @@
+
+lib_LTLIBRARIES = libapihashing.la
+
+libdir = $(pluginslibdir)
+
+
+if BUILD_PYTHON_PACKAGE
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN/../chrysalide-libs:$$ORIGIN'
+
+else
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN'
+
+endif
+
+if BUILD_PYTHON3_BINDINGS
+
+PYTHON3_LIBADD = python/libapihashingpython.la
+
+if BUILD_DISCARD_LOCAL
+
+if BUILD_PYTHON_PACKAGE
+PYTHON3_RUN_PATH = -Wl,-rpath,'$$ORIGIN/..'
+else
+PYTHON3_RUN_PATH = -Wl,-rpath,'$$ORIGIN'
+endif
+
+else
+
+PYTHON3_RUN_PATH = -Wl,-rpath,$(abs_top_srcdir)/plugins/pychrysalide/.libs
+
+endif
+
+PYTHON3_LDFLAGS = $(PYTHON3_RUN_PATH) -L$(top_srcdir)/plugins/pychrysalide/.libs -l:pychrysalide.so
+
+PYTHON3_SUBDIRS = python
+
+endif
+
+
+libapihashing_la_SOURCES = \
+ apihash.h apihash.c \
+ core.h core.c
+
+libapihashing_la_LIBADD = \
+ $(PYTHON3_LIBADD) \
+ classics/libapihashingclassics.la \
+ custom/libapihashingcustom.la
+
+libapihashing_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
+libapihashing_la_LDFLAGS = \
+ -avoid-version \
+ -L$(top_srcdir)/src/.libs -lchrysacore \
+ -L$(top_srcdir)/plugins/pe/.libs -lpe \
+ $(RUN_PATH) $(PYTHON3_LDFLAGS)
+
+
+devdir = $(includedir)/chrysalide/$(subdir)
+
+dev_HEADERS = $(libapihashing_la_SOURCES:%c=)
+
+
+SUBDIRS = $(PYTHON3_SUBDIRS) classics custom