summaryrefslogtreecommitdiff
path: root/plugins/apihashing/custom/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/apihashing/custom/Makefile.am')
-rw-r--r--plugins/apihashing/custom/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/plugins/apihashing/custom/Makefile.am b/plugins/apihashing/custom/Makefile.am
new file mode 100644
index 0000000..026addc
--- /dev/null
+++ b/plugins/apihashing/custom/Makefile.am
@@ -0,0 +1,18 @@
+
+noinst_LTLIBRARIES = libapihashingcustom.la
+
+libapihashingcustom_la_SOURCES = \
+ add1505-shl5.h add1505-shl5.c \
+ enigma-murmur.h enigma-murmur.c \
+ imul21-add.h imul21-add.c \
+ imul83-add.h imul83-add.c \
+ sll1-add-hash32.h sll1-add-hash32.c \
+ sub-index1.h sub-index1.c \
+ sub42.h sub42.c
+
+libapihashingcustom_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
+
+devdir = $(includedir)/chrysalide-$(subdir)
+
+dev_HEADERS = $(libapihashingcustom_la_SOURCES:%c=)