summaryrefslogtreecommitdiff
path: root/plugins/arm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/arm/Makefile.am')
-rw-r--r--plugins/arm/Makefile.am33
1 files changed, 15 insertions, 18 deletions
diff --git a/plugins/arm/Makefile.am b/plugins/arm/Makefile.am
index a37cbbd..3470256 100644
--- a/plugins/arm/Makefile.am
+++ b/plugins/arm/Makefile.am
@@ -35,23 +35,25 @@ PYTHON3_SUBDIRS = python
endif
-libarm_la_SOURCES = \
- cond.h \
- context-int.h \
- context.h context.c \
- core.h core.c \
- instruction-int.h \
- instruction.h instruction.c \
- link.h link.c \
- processor-int.h \
- processor.h processor.c \
- register-int.h \
+libarm_la_SOURCES = \
+ cond.h \
+ context-int.h \
+ context.h context.c \
+ core.h core.c \
+ instruction-int.h \
+ instruction.h instruction.c \
+ link.h link.c \
+ processor-int.h \
+ processor.h processor.c \
+ register-int.h \
register.h register.c
-libarm_la_LIBADD = \
- $(PYTHON3_LIBADD) \
+libarm_la_LIBADD = \
+ $(PYTHON3_LIBADD) \
v7/libarmv7.la
+libarm_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libarm_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -63,9 +65,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libarm_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
-
SUBDIRS = v7 $(PYTHON3_SUBDIRS)