summaryrefslogtreecommitdiff
path: root/plugins/arm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/arm/Makefile.am')
-rw-r--r--plugins/arm/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/plugins/arm/Makefile.am b/plugins/arm/Makefile.am
new file mode 100644
index 0000000..3e691f4
--- /dev/null
+++ b/plugins/arm/Makefile.am
@@ -0,0 +1,32 @@
+
+lib_LTLIBRARIES = libarm.la
+
+libarm_la_SOURCES = \
+ cond.h \
+ context-int.h \
+ context.h context.c \
+ core.h core.c \
+ instruction-int.h \
+ instruction.h instruction.c \
+ link.h link.c \
+ processor-int.h \
+ processor.h processor.c \
+ register-int.h \
+ register.h register.c
+
+libarm_la_LIBADD = \
+ python/libarmpython.la \
+ v7/libarmv7.la
+
+libarm_la_CFLAGS = $(AM_CFLAGS)
+
+libarm_la_LDFLAGS = \
+ $(LIBPYTHON_LIBS) $(LIBPYGOBJECT_LIBS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+
+SUBDIRS = python v7