summaryrefslogtreecommitdiff
path: root/plugins/arm/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/arm/python/Makefile.am')
-rw-r--r--plugins/arm/python/Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/plugins/arm/python/Makefile.am b/plugins/arm/python/Makefile.am
index f09baee..931b2b9 100644
--- a/plugins/arm/python/Makefile.am
+++ b/plugins/arm/python/Makefile.am
@@ -1,15 +1,16 @@
noinst_LTLIBRARIES = libarmpython.la
-libarmpython_la_SOURCES = \
- instruction.h instruction.c \
- module.h module.c \
+libarmpython_la_SOURCES = \
+ instruction.h instruction.c \
+ module.h module.c \
processor.h processor.c
-libarmpython_la_LIBADD = \
+libarmpython_la_LIBADD = \
v7/libarmpythonv7.la
-libarmpython_la_LDFLAGS =
+libarmpython_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
devdir = $(includedir)/chrysalide/$(subdir)
@@ -17,9 +18,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libarmpython_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
- -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = v7