summaryrefslogtreecommitdiff
path: root/plugins/arm/python/v7/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/arm/python/v7/Makefile.am')
-rw-r--r--plugins/arm/python/v7/Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/plugins/arm/python/v7/Makefile.am b/plugins/arm/python/v7/Makefile.am
index 06dc4af..a350d90 100644
--- a/plugins/arm/python/v7/Makefile.am
+++ b/plugins/arm/python/v7/Makefile.am
@@ -1,20 +1,15 @@
noinst_LTLIBRARIES = libarmpythonv7.la
-libarmpythonv7_la_SOURCES = \
- instruction.h instruction.c \
- module.h module.c \
+libarmpythonv7_la_SOURCES = \
+ instruction.h instruction.c \
+ module.h module.c \
processor.h processor.c
-libarmpythonv7_la_LDFLAGS =
+libarmpythonv7_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libarmpythonv7_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
- -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)