summaryrefslogtreecommitdiff
path: root/plugins/arm/v7/operands/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/arm/v7/operands/Makefile.am')
-rw-r--r--plugins/arm/v7/operands/Makefile.am27
1 files changed, 11 insertions, 16 deletions
diff --git a/plugins/arm/v7/operands/Makefile.am b/plugins/arm/v7/operands/Makefile.am
index 31f6a8a..fa7ab8b 100644
--- a/plugins/arm/v7/operands/Makefile.am
+++ b/plugins/arm/v7/operands/Makefile.am
@@ -1,26 +1,21 @@
noinst_LTLIBRARIES = libarmv7operands.la
-libarmv7operands_la_SOURCES = \
- estate.h estate.c \
- iflags.h iflags.c \
- it.h it.c \
- limitation.h limitation.c \
- maccess.h maccess.c \
- offset.h offset.c \
- register.h register.c \
- reglist.h reglist.c \
- rotation.h rotation.c \
+libarmv7operands_la_SOURCES = \
+ estate.h estate.c \
+ iflags.h iflags.c \
+ it.h it.c \
+ limitation.h limitation.c \
+ maccess.h maccess.c \
+ offset.h offset.c \
+ register.h register.c \
+ reglist.h reglist.c \
+ rotation.h rotation.c \
shift.h shift.c
-libarmv7operands_la_LIBADD =
+libarmv7operands_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libarmv7operands_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)