summaryrefslogtreecommitdiff
path: root/plugins/bhash/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/bhash/Makefile.am')
-rw-r--r--plugins/bhash/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/plugins/bhash/Makefile.am b/plugins/bhash/Makefile.am
index 45c5ee0..31daeb1 100644
--- a/plugins/bhash/Makefile.am
+++ b/plugins/bhash/Makefile.am
@@ -45,9 +45,11 @@ libbhash_la_SOURCES = \
tlsh.h tlsh.c \
rich.h rich.c
-libbhash_la_LIBADD = \
+libbhash_la_LIBADD = \
$(PYTHON3_LIBADD)
+libbhash_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libbhash_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -60,8 +62,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libbhash_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = $(PYTHON3_SUBDIRS)