summaryrefslogtreecommitdiff
path: root/plugins/bhash/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/bhash/python/Makefile.am')
-rw-r--r--plugins/bhash/python/Makefile.am17
1 files changed, 6 insertions, 11 deletions
diff --git a/plugins/bhash/python/Makefile.am b/plugins/bhash/python/Makefile.am
index 822a716..6dd127c 100644
--- a/plugins/bhash/python/Makefile.am
+++ b/plugins/bhash/python/Makefile.am
@@ -1,21 +1,16 @@
noinst_LTLIBRARIES = libbhashpython.la
-libbhashpython_la_SOURCES = \
- imphash.h imphash.c \
- module.h module.c \
- tlsh.h tlsh.c \
+libbhashpython_la_SOURCES = \
+ imphash.h imphash.c \
+ module.h module.c \
+ tlsh.h tlsh.c \
rich.h rich.c
-libbhashpython_la_LDFLAGS =
+libbhashpython_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libbhashpython_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
- -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)