summaryrefslogtreecommitdiff
path: root/plugins/bootimg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/bootimg/Makefile.am')
-rw-r--r--plugins/bootimg/Makefile.am16
1 files changed, 7 insertions, 9 deletions
diff --git a/plugins/bootimg/Makefile.am b/plugins/bootimg/Makefile.am
index ada1e4e..623c555 100644
--- a/plugins/bootimg/Makefile.am
+++ b/plugins/bootimg/Makefile.am
@@ -35,15 +35,17 @@ PYTHON3_SUBDIRS = python
endif
-libbootimg_la_SOURCES = \
- core.h core.c \
- bootimg-def.h \
- format-int.h format-int.c \
+libbootimg_la_SOURCES = \
+ core.h core.c \
+ bootimg-def.h \
+ format-int.h format-int.c \
format.h format.c
-libbootimg_la_LIBADD = \
+libbootimg_la_LIBADD = \
$(PYTHON3_LIBADD)
+libbootimg_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libbootimg_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -55,8 +57,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libbootimg_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = $(PYTHON3_SUBDIRS)