summaryrefslogtreecommitdiff
path: root/plugins/dalvik/v35/opdefs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/dalvik/v35/opdefs/Makefile.am')
-rw-r--r--plugins/dalvik/v35/opdefs/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/plugins/dalvik/v35/opdefs/Makefile.am b/plugins/dalvik/v35/opdefs/Makefile.am
index f660e3d..0684c53 100644
--- a/plugins/dalvik/v35/opdefs/Makefile.am
+++ b/plugins/dalvik/v35/opdefs/Makefile.am
@@ -26,12 +26,10 @@ D2C_SPECIFIC = --op-prefix=DALVIK_OPT_
FIXED_C_INCLUDES = \
\#include <stdint.h> \
\n \
+ \n\#include "identifiers.h" \
\n\#include "../instruction.h" \
\n\#include "../operand.h" \
- \n\#include "../../fetch.h" \
- \n\#include "../../helpers.h" \
- \n\#include "../../link.h" \
- \n\#include "../../post.h"
+ \n\#include "../../helpers.h"
FIXED_H_INCLUDES = \
\#include <stdint.h> \
@@ -42,6 +40,11 @@ FIXED_H_INCLUDES = \
\n \
\n\#include "../processor.h"
+FIXED_H_HOOKS_INCLUDES = \
+ \#include "../../fetch.h" \
+ \n\#include "../../link.h" \
+ \n\#include "../../post.h"
+
# for (( i = 0; i < 256; i++)); do def=$(ls `printf "*_%02x.d" $i` 2> /dev/null); test -z "$def" || echo -e "\t$def\t\t\t\t\t\t\t\\" ; done
DALVIK_DEFS = \