summaryrefslogtreecommitdiff
path: root/plugins/dex/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/dex/python/Makefile.am')
-rw-r--r--plugins/dex/python/Makefile.am27
1 files changed, 11 insertions, 16 deletions
diff --git a/plugins/dex/python/Makefile.am b/plugins/dex/python/Makefile.am
index e91630e..b627157 100644
--- a/plugins/dex/python/Makefile.am
+++ b/plugins/dex/python/Makefile.am
@@ -1,26 +1,21 @@
noinst_LTLIBRARIES = libdexpython.la
-libdexpython_la_SOURCES = \
- class.h class.c \
- constants.h constants.c \
- field.h field.c \
- format.h format.c \
- method.h method.c \
- module.h module.c \
- pool.h pool.c \
- routine.h routine.c \
+libdexpython_la_SOURCES = \
+ class.h class.c \
+ constants.h constants.c \
+ field.h field.c \
+ format.h format.c \
+ method.h method.c \
+ module.h module.c \
+ pool.h pool.c \
+ routine.h routine.c \
translate.h translate.c
-libdexpython_la_LDFLAGS =
+libdexpython_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libdexpython_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
- -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)