summaryrefslogtreecommitdiff
path: root/plugins/dexbnf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/dexbnf/Makefile.am')
-rw-r--r--plugins/dexbnf/Makefile.am20
1 files changed, 9 insertions, 11 deletions
diff --git a/plugins/dexbnf/Makefile.am b/plugins/dexbnf/Makefile.am
index 51598ce..222cc35 100644
--- a/plugins/dexbnf/Makefile.am
+++ b/plugins/dexbnf/Makefile.am
@@ -34,17 +34,19 @@ PYTHON3_SUBDIRS = python
endif
-libdexbnf_la_SOURCES = \
- context.h context.c \
- core.h core.c \
- demangler.h demangler.c \
- simple.h simple.c \
- shorty.h shorty.c \
+libdexbnf_la_SOURCES = \
+ context.h context.c \
+ core.h core.c \
+ demangler.h demangler.c \
+ simple.h simple.c \
+ shorty.h shorty.c \
type.h type.c
-libdexbnf_la_LIBADD = \
+libdexbnf_la_LIBADD = \
$(PYTHON3_LIBADD)
+libdexbnf_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libdexbnf_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -56,8 +58,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libdexbnf_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = $(PYTHON3_SUBDIRS)