summaryrefslogtreecommitdiff
path: root/plugins/elf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/elf/Makefile.am')
-rw-r--r--plugins/elf/Makefile.am32
1 files changed, 15 insertions, 17 deletions
diff --git a/plugins/elf/Makefile.am b/plugins/elf/Makefile.am
index 880ae78..677cf93 100644
--- a/plugins/elf/Makefile.am
+++ b/plugins/elf/Makefile.am
@@ -37,23 +37,25 @@ PYTHON3_SUBDIRS = python
endif
-libelf_la_SOURCES = \
- core.h core.c \
- elf-int.h elf-int.c \
- elf_def.h \
- elf_def_arm.h \
- format.h format.c \
- dynamic.h dynamic.c \
- helper_arm.h helper_arm.c \
- loading.h loading.c \
- program.h program.c \
- section.h section.c \
- strings.h strings.c \
+libelf_la_SOURCES = \
+ core.h core.c \
+ elf-int.h elf-int.c \
+ elf_def.h \
+ elf_def_arm.h \
+ format.h format.c \
+ dynamic.h dynamic.c \
+ helper_arm.h helper_arm.c \
+ loading.h loading.c \
+ program.h program.c \
+ section.h section.c \
+ strings.h strings.c \
symbols.h symbols.c
-libelf_la_LIBADD = \
+libelf_la_LIBADD = \
$(PYTHON3_LIBADD)
+libelf_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libelf_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -65,8 +67,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libelf_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = $(PYTHON3_SUBDIRS)