summaryrefslogtreecommitdiff
path: root/plugins/encodings/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/encodings/Makefile.am')
-rw-r--r--plugins/encodings/Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/plugins/encodings/Makefile.am b/plugins/encodings/Makefile.am
new file mode 100644
index 0000000..6dd71fb
--- /dev/null
+++ b/plugins/encodings/Makefile.am
@@ -0,0 +1,64 @@
+
+lib_LTLIBRARIES = libencodings.la
+
+libdir = $(pluginslibdir)
+
+
+if BUILD_PYTHON_PACKAGE
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN/../chrysalide-libs:$$ORIGIN'
+
+else
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN'
+
+endif
+
+if BUILD_PYTHON3_BINDINGS
+
+PYTHON3_LIBADD = python/libencodingspython.la
+
+if BUILD_DISCARD_LOCAL
+
+if BUILD_PYTHON_PACKAGE
+PYTHON3_RUN_PATH = -Wl,-rpath,'$$ORIGIN/..'
+else
+PYTHON3_RUN_PATH = -Wl,-rpath,'$$ORIGIN'
+endif
+
+else
+
+PYTHON3_RUN_PATH = -Wl,-rpath,$(abs_top_srcdir)/plugins/pychrysalide/.libs
+
+endif
+
+PYTHON3_LDFLAGS = $(PYTHON3_RUN_PATH) -L$(top_srcdir)/plugins/pychrysalide/.libs -l:pychrysalide.so
+
+PYTHON3_SUBDIRS = python
+
+endif
+
+
+libencodings_la_SOURCES = \
+ base64.h base64.c \
+ core.h core.c
+
+libencodings_la_LIBADD = \
+ $(PYTHON3_LIBADD) \
+ rost/libencodingsrost.la
+
+libencodings_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
+libencodings_la_LDFLAGS = \
+ -avoid-version \
+ -L$(top_srcdir)/src/.libs -lchrysacore \
+ -L$(top_srcdir)/plugins/pe/.libs -lpe \
+ $(RUN_PATH) $(PYTHON3_LDFLAGS)
+
+
+devdir = $(includedir)/chrysalide/$(subdir)
+
+dev_HEADERS = $(libencodings_la_SOURCES:%c=)
+
+
+SUBDIRS = $(PYTHON3_SUBDIRS) rost