summaryrefslogtreecommitdiff
path: root/plugins/encodings/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/encodings/python/Makefile.am')
-rw-r--r--plugins/encodings/python/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/plugins/encodings/python/Makefile.am b/plugins/encodings/python/Makefile.am
new file mode 100644
index 0000000..523a6f4
--- /dev/null
+++ b/plugins/encodings/python/Makefile.am
@@ -0,0 +1,21 @@
+
+noinst_LTLIBRARIES = libencodingspython.la
+
+libencodingspython_la_SOURCES = \
+ base64.h base64.c \
+ module.h module.c
+
+libencodingspython_la_LIBADD = \
+ rost/libencodingspythonrost.la
+
+libencodingspython_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) \
+ $(LIBPYTHON_INTERPRETER_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+
+
+devdir = $(includedir)/chrysalide/$(subdir)
+
+dev_HEADERS = $(libencodingspython_la_SOURCES:%c=)
+
+
+SUBDIRS = rost