summaryrefslogtreecommitdiff
path: root/plugins/jvm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/jvm/Makefile.am')
-rw-r--r--plugins/jvm/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/plugins/jvm/Makefile.am b/plugins/jvm/Makefile.am
new file mode 100644
index 0000000..fc4ee0b
--- /dev/null
+++ b/plugins/jvm/Makefile.am
@@ -0,0 +1,35 @@
+
+noinst_LTLIBRARIES = libarchjvm.la
+
+libarchjvm_la_SOURCES = \
+ instruction.h instruction.c \
+ op_add.c \
+ op_const.c \
+ op_convert.c \
+ op_dup.c \
+ op_getput.c \
+ op_invoke.c \
+ op_load.c \
+ op_monitor.c \
+ op_nop.c \
+ op_pop.c \
+ op_store.c \
+ op_ret.c \
+ opcodes.h \
+ operand.h operand.c \
+ processor.h processor.c
+
+libarchjvm_la_CFLAGS = $(AM_CFLAGS)
+
+
+devdir = $(includedir)/chrysalide/$(subdir:src/%=%)
+
+dev_HEADERS = $(libarchjvm_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+
+SUBDIRS =