summaryrefslogtreecommitdiff
path: root/plugins/lnxsyscalls/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/lnxsyscalls/Makefile.am')
-rw-r--r--plugins/lnxsyscalls/Makefile.am25
1 files changed, 9 insertions, 16 deletions
diff --git a/plugins/lnxsyscalls/Makefile.am b/plugins/lnxsyscalls/Makefile.am
index 9c5158f..21feaa5 100644
--- a/plugins/lnxsyscalls/Makefile.am
+++ b/plugins/lnxsyscalls/Makefile.am
@@ -14,17 +14,17 @@ RUN_PATH = -Wl,-rpath,'$$ORIGIN'
endif
-liblnxsyscalls_la_SOURCES = \
- collect.h collect.c \
- core.h core.c \
- db.h db.c \
- hops.h \
- hops_armv7.h hops_armv7.c \
- hunter.h hunter.c \
- syscall.h syscall.c \
+liblnxsyscalls_la_SOURCES = \
+ collect.h collect.c \
+ core.h core.c \
+ db.h db.c \
+ hops.h \
+ hops_armv7.h hops_armv7.c \
+ hunter.h hunter.c \
+ syscall.h syscall.c \
writer.h writer.c
-liblnxsyscalls_la_LIBADD =
+liblnxsyscalls_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
liblnxsyscalls_la_LDFLAGS = \
-avoid-version \
@@ -44,10 +44,3 @@ dbdir = $(pluginsdatadir)
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(liblnxsyscalls_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
-SUBDIRS =