summaryrefslogtreecommitdiff
path: root/plugins/pe/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/pe/Makefile.am')
-rw-r--r--plugins/pe/Makefile.am24
1 files changed, 11 insertions, 13 deletions
diff --git a/plugins/pe/Makefile.am b/plugins/pe/Makefile.am
index 038b8c5..e9cd482 100644
--- a/plugins/pe/Makefile.am
+++ b/plugins/pe/Makefile.am
@@ -37,19 +37,21 @@ PYTHON3_SUBDIRS = python
endif
-libpe_la_SOURCES = \
- core.h core.c \
- pe-int.h pe-int.c \
- format.h format.c \
- pe_def.h \
- rich.h rich.c \
- routine.h routine.c \
- section.h section.c \
+libpe_la_SOURCES = \
+ core.h core.c \
+ pe-int.h pe-int.c \
+ format.h format.c \
+ pe_def.h \
+ rich.h rich.c \
+ routine.h routine.c \
+ section.h section.c \
symbols.h symbols.c
-libpe_la_LIBADD = \
+libpe_la_LIBADD = \
$(PYTHON3_LIBADD)
+libpe_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libpe_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -61,8 +63,4 @@ devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libpe_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = $(PYTHON3_SUBDIRS)