summaryrefslogtreecommitdiff
path: root/plugins/python/androperms/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/python/androperms/Makefile.am')
-rw-r--r--plugins/python/androperms/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/plugins/python/androperms/Makefile.am b/plugins/python/androperms/Makefile.am
index 3d1755c..f44be3c 100644
--- a/plugins/python/androperms/Makefile.am
+++ b/plugins/python/androperms/Makefile.am
@@ -3,10 +3,18 @@ andropermsdir = $(datadir)/openida/plugins/python/androperms
androperms_DATA = \
__init__.py \
+ androperms.db \
androperms.py \
defs.py \
manifest.py \
+ panel.py \
parser.py \
reader.py \
stack.py \
string.py
+
+androperms.db:
+ @tmpzip=`tempfile` ; \
+ wget http://www.android-permissions.org/permissionmap.zip -O $$tmpzip ; \
+ unzip -p $$tmpzip permissionmap/APICalls.txt | tail -n +2 - > androperms.db ; \
+ rm $$tmpzip