summaryrefslogtreecommitdiff
path: root/plugins/readdex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/readdex/Makefile.am')
-rw-r--r--plugins/readdex/Makefile.am17
1 files changed, 7 insertions, 10 deletions
diff --git a/plugins/readdex/Makefile.am b/plugins/readdex/Makefile.am
index b21f855..b2099fb 100644
--- a/plugins/readdex/Makefile.am
+++ b/plugins/readdex/Makefile.am
@@ -15,13 +15,15 @@ RUN_PATH = -Wl,-rpath,'$$ORIGIN'
endif
-libreaddex_la_SOURCES = \
- class.h class.c \
- code.h code.c \
- header.h header.c \
- ids.h ids.c \
+libreaddex_la_SOURCES = \
+ class.h class.c \
+ code.h code.c \
+ header.h header.c \
+ ids.h ids.c \
reader.h reader.c
+libreaddex_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libreaddex_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -33,8 +35,3 @@ libreaddex_la_LDFLAGS = \
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libreaddex_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)