summaryrefslogtreecommitdiff
path: root/plugins/readelf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/readelf/Makefile.am')
-rw-r--r--plugins/readelf/Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/plugins/readelf/Makefile.am b/plugins/readelf/Makefile.am
index 0ca002b..7e662ee 100644
--- a/plugins/readelf/Makefile.am
+++ b/plugins/readelf/Makefile.am
@@ -15,13 +15,15 @@ RUN_PATH = -Wl,-rpath,'$$ORIGIN'
endif
-libreadelf_la_SOURCES = \
- header.h header.c \
- program.h program.c \
- reader.h reader.c \
- section.h section.c \
+libreadelf_la_SOURCES = \
+ header.h header.c \
+ program.h program.c \
+ reader.h reader.c \
+ section.h section.c \
strtab.h strtab.c
+libreadelf_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libreadelf_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -29,11 +31,7 @@ libreadelf_la_LDFLAGS = \
-L$(top_srcdir)/plugins/fmtp/.libs -lfmtp \
$(RUN_PATH)
+
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libreadelf_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)