summaryrefslogtreecommitdiff
path: root/plugins/readelf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/readelf/Makefile.am')
-rw-r--r--plugins/readelf/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/plugins/readelf/Makefile.am b/plugins/readelf/Makefile.am
index d14429c..5e3496d 100644
--- a/plugins/readelf/Makefile.am
+++ b/plugins/readelf/Makefile.am
@@ -3,6 +3,7 @@ lib_LTLIBRARIES = libreadelf.la
libdir = $(pluginsdir)
+
libreadelf_la_SOURCES = \
header.h header.c \
program.h program.c \
@@ -16,6 +17,11 @@ libreadelf_la_LDFLAGS = -L$(top_srcdir)/plugins/fmtp/.libs -lfmtp \
-L$(top_srcdir)/src/.libs -lchrysacore
+devdir = $(includedir)/chrysalide-$(subdir)
+
+dev_HEADERS = $(libreadelf_la_SOURCES:%c=)
+
+
AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src -I$(top_srcdir)
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)