summaryrefslogtreecommitdiff
path: root/plugins/readmc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/readmc/Makefile.am')
-rw-r--r--plugins/readmc/Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/plugins/readmc/Makefile.am b/plugins/readmc/Makefile.am
index fa13fb2..51a8552 100644
--- a/plugins/readmc/Makefile.am
+++ b/plugins/readmc/Makefile.am
@@ -15,14 +15,16 @@ RUN_PATH = -Wl,-rpath,'$$ORIGIN'
endif
-libreadmc_la_SOURCES = \
- header.h header.c \
- reader.h reader.c \
- text.h text.c \
- v21.h v21.c \
- v23.h v23.c \
+libreadmc_la_SOURCES = \
+ header.h header.c \
+ reader.h reader.c \
+ text.h text.c \
+ v21.h v21.c \
+ v23.h v23.c \
v24.h v24.c
+libreadmc_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
+
libreadmc_la_LDFLAGS = \
-avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
@@ -34,8 +36,3 @@ libreadmc_la_LDFLAGS = \
devdir = $(includedir)/chrysalide/$(subdir)
dev_HEADERS = $(libreadmc_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)