summaryrefslogtreecommitdiff
path: root/plugins/yaml/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/yaml/python/Makefile.am')
-rw-r--r--plugins/yaml/python/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/plugins/yaml/python/Makefile.am b/plugins/yaml/python/Makefile.am
new file mode 100644
index 0000000..8a8d960
--- /dev/null
+++ b/plugins/yaml/python/Makefile.am
@@ -0,0 +1,22 @@
+
+noinst_LTLIBRARIES = libyamlpython.la
+
+libyamlpython_la_SOURCES = \
+ line.h line.c \
+ module.h module.c \
+ node.h node.c \
+ reader.h reader.c \
+ tree.h tree.c
+
+libyamlpython_la_LDFLAGS =
+
+
+devdir = $(includedir)/chrysalide-$(subdir)
+
+dev_HEADERS = $(libyamlpython_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I$(top_srcdir)/src -DNO_IMPORT_PYGOBJECT
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)