summaryrefslogtreecommitdiff
path: root/src/arch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/arch/Makefile.am')
-rw-r--r--src/arch/Makefile.am45
1 files changed, 20 insertions, 25 deletions
diff --git a/src/arch/Makefile.am b/src/arch/Makefile.am
index 8a2eea3..bdfceb7 100644
--- a/src/arch/Makefile.am
+++ b/src/arch/Makefile.am
@@ -1,29 +1,29 @@
noinst_LTLIBRARIES = libarch.la
-libarch_la_SOURCES = \
- archbase.h archbase.c \
- context-int.h \
- context.h context.c \
- instriter.h instriter.c \
- instruction-int.h \
- instruction.h instruction.c \
- link.h link.c \
- operand-int.h operand-int.c \
- operand.h operand.c \
- post.h post.c \
- processor-int.h \
- processor.h processor.c \
- register-int.h \
- register.h register.c \
- storage.h storage.c \
+libarch_la_SOURCES = \
+ archbase.h archbase.c \
+ context-int.h \
+ context.h context.c \
+ instriter.h instriter.c \
+ instruction-int.h \
+ instruction.h instruction.c \
+ link.h link.c \
+ operand-int.h operand-int.c \
+ operand.h operand.c \
+ post.h post.c \
+ processor-int.h \
+ processor.h processor.c \
+ register-int.h \
+ register.h register.c \
+ storage.h storage.c \
vmpa.h vmpa.c
-libarch_la_LIBADD = \
- instructions/libarchinstructions.la \
- operands/libarchoperands.la
+libarch_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
-libarch_la_LDFLAGS =
+libarch_la_LIBADD = \
+ instructions/libarchinstructions.la \
+ operands/libarchoperands.la
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
@@ -31,9 +31,4 @@ devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libarch_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
-
SUBDIRS = instructions operands