summaryrefslogtreecommitdiff
path: root/src/arch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/arch/Makefile.am')
-rw-r--r--src/arch/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/arch/Makefile.am b/src/arch/Makefile.am
new file mode 100644
index 0000000..7f231de
--- /dev/null
+++ b/src/arch/Makefile.am
@@ -0,0 +1,22 @@
+
+lib_LIBRARIES = libarch.a
+
+libarch_a_SOURCES = \
+ instruction-int.h \
+ instruction.h instruction.c \
+ operand-int.h \
+ operand.h operand.c \
+ processor-int.h \
+ processor.h processor.c
+
+libarch_a_CFLAGS = $(AM_CFLAGS)
+
+
+INCLUDES =
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
+
+
+SUBDIRS = x86