summaryrefslogtreecommitdiff
path: root/src/arch/dalvik/opdefs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/arch/dalvik/opdefs/Makefile.am')
-rw-r--r--src/arch/dalvik/opdefs/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/arch/dalvik/opdefs/Makefile.am b/src/arch/dalvik/opdefs/Makefile.am
index eebf04e..055e8a4 100644
--- a/src/arch/dalvik/opdefs/Makefile.am
+++ b/src/arch/dalvik/opdefs/Makefile.am
@@ -16,11 +16,17 @@ D2C_PREFIX = DALVIK_OPT_
D2C_ENCODINGS = \
-e none
+D2C_MACROS = \
+ -M SetInsFlag=g_arch_instruction_set_flag
+
FIXED_C_INCLUDES = \
\n\#include \<stdint.h\> \
\n \
+ \n\#include \"..\/fetch.h\" \
\n\#include \"..\/helpers.h\" \
\n\#include \"..\/instruction.h\" \
+ \n\#include \"..\/link.h\" \
+ \n\#include \"..\/post.h\" \
\n\#include \"..\/processor.h\" \
\n\#include \"..\/..\/context.h\" \
\n\#include \"..\/..\/..\/analysis\/content.h\" \