summaryrefslogtreecommitdiff
path: root/src/arch/operands/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/arch/operands/Makefile.am')
-rw-r--r--src/arch/operands/Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/src/arch/operands/Makefile.am b/src/arch/operands/Makefile.am
index 0cb5b02..f2a8767 100644
--- a/src/arch/operands/Makefile.am
+++ b/src/arch/operands/Makefile.am
@@ -4,7 +4,9 @@ noinst_LTLIBRARIES = libarchoperands.la
libarchoperands_la_SOURCES = \
feeder-int.h \
feeder.h feeder.c \
+ immediate-int.h \
immediate.h immediate.c \
+ known.h known.c \
register-int.h \
register.h register.c \
proxy-int.h \
@@ -16,19 +18,9 @@ libarchoperands_la_SOURCES = \
targetable-int.h \
targetable.h targetable.c
-libarchoperands_la_LIBADD =
-
-libarchoperands_la_LDFLAGS =
+libarchoperands_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libarchoperands_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
-
-SUBDIRS =