summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
index 58ffaa8..42326c9 100644
--- a/src/arch/x86/Makefile.am
+++ b/src/arch/x86/Makefile.am
@@ -7,6 +7,7 @@ libarchx86_a_SOURCES = \
op_add.c \
op_and.c \
op_call.c \
+ op_cld.c \
op_cmp.c \
op_dec.c \
op_hlt.c \
@@ -15,9 +16,11 @@ libarchx86_a_SOURCES = \
op_jump.c \
op_lea.c \
op_leave.c \
- op_nop.c \
op_mov.c \
+ op_movsx.c \
op_movzx.c \
+ op_nop.c \
+ op_not.c \
op_or.c \
op_pop.c \
op_push.c \