summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
index 8f49e54..063a7ce 100644
--- a/src/arch/x86/Makefile.am
+++ b/src/arch/x86/Makefile.am
@@ -2,7 +2,7 @@
noinst_LTLIBRARIES = libarchx86.la
libarchx86_la_SOURCES = \
- instruction.h \
+ instruction.h instruction.c \
op_adc.c \
op_add.c \
op_and.c \
@@ -17,8 +17,6 @@ libarchx86_la_SOURCES = \
op_lea.c \
op_leave.c \
op_mov.c \
- op_movsx.c \
- op_movzx.c \
op_nop.c \
op_not.c \
op_or.c \
@@ -35,10 +33,15 @@ libarchx86_la_SOURCES = \
op_shr.c \
op_sub.c \
op_test.c \
+ op_xchg.c \
op_xor.c \
opcodes.h \
operand.h operand.c \
- processor.h processor.c
+ processor.h processor.c \
+ registers.h registers.c
+
+# op_movsx.c
+# op_movzx.c
libarchx86_la_CFLAGS = $(AM_CFLAGS)