summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 28e5459..1a8f8c4 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -9,7 +9,7 @@ libcommon_la_SOURCES = \
bits.h bits.c \
compression.h compression.c \
cpp.h \
- curl.h curl.c \
+ cpu.h cpu.c \
dllist.h dllist.c \
endianness.h endianness.c \
environment.h environment.c \
@@ -17,6 +17,7 @@ libcommon_la_SOURCES = \
hex.h hex.c \
ibuf.h ibuf.c \
io.h io.c \
+ itoa.h itoa.c \
fnv1a.h fnv1a.c \
leb128.h leb128.c \
macros.h \
@@ -27,20 +28,29 @@ libcommon_la_SOURCES = \
shuffle.h shuffle.c \
sort.h sort.c \
sqlite.h sqlite.c \
+ szstr.h \
utf8.h utf8.c \
xdg.h xdg.c \
xml.h xml.c
-libcommon_la_LDFLAGS = $(LIBGTK_LIBS) $(LIBXML_LIBS) $(LIBCURL_LIBS)
+if BUILD_CURL_SUPPORT
+libcommon_la_SOURCES += \
+ curl.h curl.c
-devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
+endif
-dev_HEADERS = $(libcommon_la_SOURCES:%c=)
+cpu.lo: CFLAGS += -mavx512f
+
+libcommon_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
+
+if BUILD_CURL_SUPPORT
+libcommon_la_CFLAGS += $(LIBCURL_CFLAGS)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBCURL_CFLAGS)
+endif
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS =
+devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
+
+dev_HEADERS = $(libcommon_la_SOURCES:%c=)