summaryrefslogtreecommitdiff
path: root/src/debug/gdbrsp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/debug/gdbrsp/Makefile.am')
-rw-r--r--src/debug/gdbrsp/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/debug/gdbrsp/Makefile.am b/src/debug/gdbrsp/Makefile.am
new file mode 100644
index 0000000..fd46f27
--- /dev/null
+++ b/src/debug/gdbrsp/Makefile.am
@@ -0,0 +1,24 @@
+
+noinst_LTLIBRARIES = libdebuggdbrsp.la
+
+libdebuggdbrsp_la_SOURCES = \
+ aops.h \
+ gdb-int.h \
+ gdb.h gdb.c \
+ helpers.h helpers.c \
+ helpers_arm.h helpers_arm.c \
+ helpers_arm64.h helpers_arm64.c \
+ packet.h packet.c \
+ stream-int.h \
+ stream.h stream.c \
+ support.h support.c \
+ target.h target.c \
+ tcp.h tcp.c \
+ utils.h utils.c
+
+libdebuggdbrsp_la_CFLAGS = $(AM_CFLAGS)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)