summaryrefslogtreecommitdiff
path: root/src/glibext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/glibext/Makefile.am')
-rw-r--r--src/glibext/Makefile.am79
1 files changed, 43 insertions, 36 deletions
diff --git a/src/glibext/Makefile.am b/src/glibext/Makefile.am
index 6bcf4b8..986bbd1 100644
--- a/src/glibext/Makefile.am
+++ b/src/glibext/Makefile.am
@@ -3,53 +3,60 @@ BUILT_SOURCES = chrysamarshal.h chrysamarshal.c
noinst_LTLIBRARIES = libglibext.la
-libglibext_la_SOURCES = \
- buffercache-int.h \
- buffercache.h buffercache.c \
- bufferline.h bufferline.c \
- bufferview.h bufferview.c \
- chrysamarshal.h chrysamarshal.c \
- configuration-int.h \
- configuration.h configuration.c \
- delayed-int.h \
- delayed.h delayed.c \
- gbinarycursor.h gbinarycursor.c \
- gbinportion-int.h \
- gbinportion.h gbinportion.c \
- gdisplayoptions.h gdisplayoptions.c \
- glinecursor-int.h \
- glinecursor.h glinecursor.c \
- gloadedpanel-int.h \
- gloadedpanel.h gloadedpanel.c \
- gnhash.h gnhash.c \
- linecolumn.h linecolumn.c \
- linegen-int.h \
- linegen.h linegen.c \
- linesegment.h linesegment.c \
- named-int.h \
- named.h named.c \
- objhole.h \
- proto.h \
- seq.h seq.c \
- signal.h signal.c \
- singleton.h singleton.c \
+libglibext_la_SOURCES = \
+ buffercache-int.h \
+ buffercache.h buffercache.c \
+ bufferline.h bufferline.c \
+ chrysamarshal.h chrysamarshal.c \
+ comparison-int.h \
+ comparison.h comparison.c \
+ configuration-int.h \
+ configuration.h configuration.c \
+ delayed-int.h \
+ delayed.h delayed.c \
+ gbinarycursor.h gbinarycursor.c \
+ gbinportion-int.h \
+ gbinportion.h gbinportion.c \
+ gdisplayoptions.h gdisplayoptions.c \
+ glinecursor-int.h \
+ glinecursor.h glinecursor.c \
+ gnhash.h gnhash.c \
+ linecolumn.h linecolumn.c \
+ linegen-int.h \
+ linegen.h linegen.c \
+ notifier.h \
+ objhole.h \
+ proto.h \
+ seq.h seq.c \
+ signal.h signal.c \
+ singleton.h singleton.c \
+ linesegment.h linesegment.c \
+ umemslice-int.h \
+ umemslice.h umemslice.c
+
+if BUILD_GTK_SUPPORT
+
+libglibext_la_SOURCES += \
+ bufferview.h bufferview.c \
+ gloadedpanel-int.h \
+ gloadedpanel.h gloadedpanel.c \
+ named-int.h \
+ named.h named.c \
widthtracker.h widthtracker.c
+endif
+
+libglibext_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
+
libglibext_la_LIBADD = \
generators/libglibextgenerators.la
-libglibext_la_LDFLAGS =
-
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libglibext_la_SOURCES:%c=)
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-
SUBDIRS = generators