summaryrefslogtreecommitdiff
path: root/src/gui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gui/Makefile.am')
-rw-r--r--src/gui/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/gui/Makefile.am b/src/gui/Makefile.am
index 1bd4130..135e724 100644
--- a/src/gui/Makefile.am
+++ b/src/gui/Makefile.am
@@ -1,6 +1,11 @@
+BUILT_SOURCES = resources.h resources.c
+
noinst_LTLIBRARIES = libgui.la
+UI_FILES = \
+ editor.ui
+
libgui_la_SOURCES = \
agroup.h agroup.c \
editor.h editor.c \
@@ -9,6 +14,7 @@ libgui_la_SOURCES = \
menubar.h menubar.c \
panel-int.h \
panel.h panel.c \
+ resources.h resources.c \
status.h status.c \
theme.h theme.c
@@ -32,3 +38,15 @@ AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
SUBDIRS = core dialogs menus panels tb
+
+
+resources.c: gresource.xml $(UI_FILES)
+ glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-source --c-name gui gresource.xml
+
+resources.h: gresource.xml
+ glib-compile-resources --target=$@ --sourcedir=$(srcdir) --generate-header --c-name gui gresource.xml
+
+
+CLEANFILES = resources.h resources.c
+
+EXTRA_DIST = gresource.xml $(UI_FILES)